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INSTALLATION GUIDE
NI-CAN™ Software and Hardware

This installation guide contains instructions to help you install your
National Instruments hardware and software. Complete documentation is
in the NI-CAN Hardware and Software Manual, which is available on your
NI-CAN Software for Windows CD in Adobe Acrobat portable document
format (PDF). Refer to the file NI-CAN Hardware and Software
Manual .pdf on the CD or in the NI-CAN\Documentation folder on
your hard drive.

The NI-CAN software on this CD supports Microsoft Windows operating
systems.

This installation guide covers all National Instruments hardware products
for CAN and LIN on the PCI, PCMCIA, PXI, and USB buses. It is written
for users already familiar with Windows.

Install the NI-CAN Software

Before installing the NI-CAN software, users must first log on as
Administrator or as a user with Administrator privileges. The NI-CAN
setup program must have Administrator privileges because the program
modifies the configuration registry of your system.

Complete the following steps to install the NI-CAN software.

1. Insert the NI-CAN Software for Windows CD into your CD-ROM
drive. The installer launches if your CD-ROM drive plays data CDs
automatically.

If the installer does not launch automatically, navigate to the CD using
Windows Explorer and launch the autorun file from your NI-CAN
Software for Windows CD.

2. The Installation Wizard guides you through the necessary steps to
install the NI-CAN software. You can go back and change values
where appropriate by clicking Back. You can exit the setup where
appropriate by clicking Cancel.

3. Power down your computer when the setup is complete.

4. Proceed to the Install the Hardware section.

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section on
ni.com/legal for more information about National Instruments trademarks. Other product and company names mentioned herein are
trademarks or trade names of their respective companies. For patents covering National Instruments products, refer to the appropriate location:
Help»Patents in your software, the patents . txt file on your CD, or ni . com/patents.
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@ Note If you are using LabVIEW Real-Time (RT), refer to the LabVIEW Real-Time (RT)
Configuration section of Chapter 2, Installation and Configuration, of the NI-CAN
Hardware and Software Manual for more information on installing the NI-CAN software
on your RT system and verifying the installation.

Install the Hardware

This section describes how to install your hardware on the PCI, PCMCIA,
PXI, and USB buses.

Install Your PCI Hardware

A Caution Before you remove the card from the package, touch the antistatic plastic package
to a metal part of your system chassis to discharge electrostatic energy, which can damage
components on your CAN card.

Make sure that your computer is powered off and unplugged.

2.  Remove the top cover (or other access panels) to give yourself access
to the computer expansion slots.

Find an unused PCI slot in your computer.

4. Remove the corresponding slot cover on the back panel of the
computer.

5. Insert the CAN card into the slot with the CAN connector(s) sticking
out of the opening on the back panel. It might be a tight fit, but do not
force the interface into place.

6. Screw the mounting bracket of the CAN card to the back panel rail of
the computer.

7. You can use a RTSI cable to connect your CAN-card RTSI interface to
other National Instruments RTSI-equipped hardware. Refer to the
RTSI section of Chapter 3, NI CAN and LIN Hardware, of the NI-CAN
Hardware and Software Manual for more information about the RTSI
interface on your CAN card.

Replace the top cover (or the access panel to the expansion slot).

9. Proceed to the Verify Your Installation section.
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Install Your PCMCIA Hardware

A Caution Before you remove the card from the package, touch the antistatic plastic package
to a metal part of your system chassis to discharge electrostatic energy, which can damage
components on your CAN card.

4,

Insert the card into a free PC Card (PCMCIA) socket.

Connect your PCMCIA-CAN cable to the card. The NI-CAN software
auto-detects which cable has been attached to the card.

You can use a PCMCIA-CAN synchronization cable to connect your
PCMCIA-CAN card to timing and triggering signals on another
device.

Refer to the PCMCIA-CAN section of Chapter 3, NI CAN and
LIN Hardware, of the NI-CAN Hardware and Software Manual for
more information about the PCMCIA-CAN synchronization interface.

Proceed to the Verify Your Installation section.

Install Your PXI Hardware

A Caution Before you remove the card from the package, touch the antistatic plastic package
to a metal part of your system chassis to discharge electrostatic energy, which can damage
components on your CAN card.

© National Instruments Corporation

Make sure that your PXI or CompactPCI chassis is powered off, and
unplug the computer.

Choose an unused PXI or CompactPCI peripheral slot.
Remove the filler panel for the peripheral slot you have chosen.

Touch a metal part on your chassis to discharge any static electricity
that might be on your clothes or body.

Insert the PXI card into the selected slot. Use the injector/ejector
handle to fully inject the card into place.

Screw the front panel of the PXI card to the front panel-mounting rail
of the PXI or CompactPCI chassis.

Proceed to the Verify Your Installation section.

3 NI-CAN Software and Hardware Installation Guide



Install Your USB Hardware

A Caution Before you remove the card from the package, touch the antistatic plastic package
to a metal part of your system chassis to discharge electrostatic energy, which can damage
components on your CAN and LIN hardware.

1. Insert the USB cable into a free USB 1.1 or 2.0 port. The NI-CAN
software auto-detects the CAN and LIN USB hardware.

2. For USB hardware with the synchronization option you can connect
your USB hardware to timing and triggering signals on another device.

Refer to the USB-847x section of Chapter 3, NI CAN and LIN
Hardware, of the NI-CAN Hardware and Software Manual for more
information about the USB-847x synchronization interface.

3. Proceed to the Verify Your Installation section.

Verify Your Installation

1. Power on your computer and start Windows.

A New Hardware Found dialog box may appear. If a dialog box
appears and does not go away on its own, choose the default option,
Install the Software Automatically (Recommended), and let the
operating system install the driver files.

2. Launch Measurement & Automation Explorer (MAX) and refresh
(press <F5> or choose View»Refresh from the menu). Your CAN and
LIN hardware should be listed now under Devices and Interfaces.
To test all detected CAN and LIN hardware, choose Tools»NI-CAN»
Test All Local Cards from the menu.

3. Proceed to the Connect the Cables section.

Connect the Cables

After you have installed the hardware, connect your cables to the hardware.
Refer to Chapter 4, Connectors and Cables, of the NI-CAN Hardware and
Software Manual for information about the cabling requirements of the
CAN and LIN hardware.
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Uninstalling the NI-CAN Software

For Windows 2000/XP, complete the following steps to uninstall the
NI-CAN software.

1. Select Start»Settings»Control Panel»Add or Remove Programs.
2. Select National Instruments Software. Click the Change button.

3. Select NI-CAN in the list of products and click Remove.

For Windows Vista, complete the following steps to uninstall the NI-CAN
software.

1. Select Start»Control Panel»Programs»Programs and Features.

2. Select National Instruments Software. Click the Uninstall/Change
button.

3. Select NI-CAN in the list of products and click Remove.

The uninstall program removes all folders, utilities, device drivers, DLLs,
and registry entries associated with the NI-CAN software. The uninstall
program removes only items that the installation program installed.

If you have added anything to a directory created by the installation
program, the uninstall program cannot delete that directory because it is not
empty after the uninstallation. Remove any remaining components
manually.

After the uninstall program completes, restart your computer.

Further Documentation

Complete documentation is in the NI-CAN Hardware and Software
Manual, which is available on your NI-CAN Software for Windows CD in
Adobe Acrobat portable document format (PDF). The manual includes a
Troubleshooting and Common Questions section with more detailed
information on installation and configuration of your NI-CAN software
and hardware. Refer to the file NI-CAN Hardware and Software
Manual .pdf on the CD or in the NI-CAN\Documentation folder on
your hard drive.
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INSTALLATIONSHINWEISE
NI-CAN"-Software und -Hardware

Die Installationshinweise helfen Thnen bei der Installation der Software
und Hardware von National Instruments. Alle weiteren Informationen
finden Sie im NI-CAN Hardware and Software Manual, das sich als
PDF-Datei auf der CD NI-CAN-Software fiir Windows befindet. Die Datei
heiit NI-CAN Hardware and Software Manual.pdf und wird im
Ordner NI-CAN\Documentation auf der Festplatte installiert.

Fiir die NI-CAN-Software auf dieser CD wird Microsoft Windows
benotigt.

Diese Installationshinweise gelten fiir die gesamte CAN- und LIN-Hard-
ware von National Instruments mit PCI-, PCMCIA-, PXI- und USB-Bus.
Es wird vorausgesetzt, dass Sie mit Windows vertraut sind.

Installieren der NI-CAN-Software

Vor der Installation von NI-CAN miissen Sie sich entweder als Admini-
strator oder als Benutzer mit Administratorrechten anmelden. Fiir das
Installationsprogramm werden Administratorrechte benétigt, da das Pro-
gramm die Konfiguration Thres Systems dndert.

Gehen Sie zur Installation von NI-CAN wie folgt vor:

1. Legen Sie die CD NI-CAN-Software fiir Windows in Thr
CD-ROM-Laufwerk ein. Wenn das CD-ROM-Laufwerk Daten-CDs
automatisch abspielt, startet nun die Installation.

Wenn die Installation nicht automatisch startet, suchen Sie die CD im
Windows-Explorer und starten Sie die autorun-Datei.

2. Der Installationsassistent fiihrt Sie durch die Installation der Software.
Uber die Schaltfliche Zuriick konnen Einstellungen bei Bedarf nach-
traglich geéndert werden. Zum Verlassen des Installationsprogramms
klicken Sie auf Abbrechen.

3. Fahren Sie Ihren Computer nach Beenden der Installation herunter.

4. Fahren Sie mit dem Abschnitt Einbauen der Hardware fort.

National Instruments, NI, ni.com und LabVIEW sind Marken der Firma National Instruments Corporation. Nahere Informationen zu den Marken von
National Instruments finden Sie im Abschnitt Terms of Use unter ni . com/1legal. Sonstige hierin erwdhnte Produkt- und Firmenbezeichnungen
sind Marken oder Handelsnamen der jeweiligen Unternehmen. Néhere Informationen iiber Patente auf Produkte von National Instruments finden Sie
unter Hilfe»Patente in Ihrer Software, in der Datei patents . txt auf hrer CD oder unter ni . com/patents.
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@ Hinweis Informationen zum Installieren und Testen von NI-CAN auf LabVIEW-
Real-Time-Systemen finden Sie im Kapitel 2, Installation and Configuration, des NI-CAN
Hardware and Software Manuals unter LabVIEW Real-Time (RT) Configuration.

Einbauen der Hardware

In diesem Abschnitt wird beschrieben, wie die CAN-Hardware mit PCI-,
PCMCIA-, PXI- oder USB-Bus angeschlossen bzw. eingebaut wird.

Einbauen von PCIl-Karten

Vorsicht! Bevor Sie die Karte aus der Verpackung nehmen, beriihren Sie mit der antista-
tischen Kunststoffverpackung ein Metallteil Thres Computergehéduses, um Schidden durch
elektrostatische Energie vorzubeugen.

1. Vergewissern Sie sich, dass der Computer ausgeschaltet und vom
Stromnetz getrennt ist.

2. Offnen Sie das Geh#use des Computers, um an die Erweiterungssteck-
plitze zu gelangen.

Suchen Sie einen freien PCI-Steckplatz.

4. Entfernen Sie die dazugehorige Abdeckung auf der Riickseite des
Computers.

5. Stecken Sie die CAN-Karte so in den Steckplatz, dass die
CAN-Anschliisse hinten aus der Offnung herausragen. Wenden Sie
beim Einstecken der CAN-Karte keine Gewalt an.

6. Verschrauben Sie die Halterung der CAN-Karte mit der Schiene auf
der Riickseite des Computers.

7. Verbinden Sie die Karte bei Bedarf iiber das RTSI-Kabel mit anderen
Karten von National Instruments, die einen entsprechenden Stecker
haben. Weitere Informationen zum RTSI-Kabel Ihrer CAN-Karte
finden Sie in Kapitel 3, NI CAN and LIN Hardware, des NI-CAN
Hardware and Software Manuals unter der Uberschrift RTSI.

8. Bringen Sie die obere Abdeckung oder die Abdeckung des Erweite-
rungssteckplatzes wieder an.

9. Fahren Sie mit dem Abschnitt Priifen der Installation fort.

NI-CAN-Software- und -Hardware-Installationshinweise 14 ni.com



Einbauen von PCMCIA-Karten

Vorsicht! Bevor Sie die Karte aus der Verpackung nehmen, beriihren Sie mit der antista-
tischen Kunststoffverpackung ein Metallteil IThres Computergehéduses, um Schiden durch
elektrostatische Energie vorzubeugen.

1. Stecken Sie die Karte in einen freien PCMCIA-Steckplatz
(PC-Card-Steckplatz) ein.

2. Verbinden Sie das PCMCIA-CAN-Kabel mit der Karte. NI-CAN
erkennt automatisch, welches Kabel mit der Karte verbunden wurde.

3. Uber ein PCMCIA-CAN-Synchronisierungskabel konnen Sie Thre
PCMCIA-CAN-Karte mit Zeit- und Triggersignalen einer anderen
Karte versorgen.

Die Synchronisierung von PCMCIA-CAN-Karten ist auch in
Kapitel 3, NI CAN and LIN Hardware, des NI-CAN Hardware and
Software Manuals unter PCMCIA-CAN beschrieben.

4. Fahren Sie mit dem Abschnitt Priifen der Installation fort.
Einbauen von PXI-Karten

Vorsicht! Bevor Sie die Karte aus der Verpackung nehmen, beriihren Sie mit der antista-
tischen Kunststoffverpackung ein Metallteil Thres Computergehéduses, um Schédden durch
elektrostatische Energie vorzubeugen.

1. Vergewissern Sie sich, dass das PXI- oder CompactPCI-Gehéuse aus-
geschaltet ist, und trennen Sie den Computer vom Stromnetz.

2. Wibhlen Sie einen freien PXI- oder CompactPCI-Steckplatz.
Entfernen Sie die Blende des Steckplatzes.

4. Beriihren Sie ein Metallteil des Computergehiuses, um sich elektrosta-
tisch zu entladen.

5. Fiihren Sie die PXI-Karte in den gewihlten Steckplatz ein. Befestigen
Sie die Karte mit dem Arretierhebel.

Schrauben Sie die Frontplatte der PXI-Karte am Gehéuse fest.

Fahren Sie mit dem Abschnitt Priifen der Installation fort.

© National Instruments Corporation 15 NI-CAN-Software- und -Hardware-Installationshinweise



AnschlieBen von USB-Geraten

Vorsicht! Bevor Sie die Karte aus der Verpackung nehmen, beriihren Sie mit der antista-
tischen Kunststoffverpackung ein Metallteil des Computergehduses, um Schiden am Gerét
durch elektrostatische Energie vorzubeugen.

1. Stecken Sie das USB-Kabel in einen freien USB-Anschluss
(1.1 oder 2.0). USB-Gerite mit CAN- oder LIN-Bus werden automa-
tisch von NI-CAN erkannt.

2. Wenn das USB-Gerit eine Synchronisierungsfunktion hat, kann es
andere Gerite mit Takt- und Triggersignalen versorgen.

Weitere Informationen zur Synchronisierungsfunktion von Geriten
des Typs USB-847x finden Sie in Kapitel 3, NI CAN and LIN
Hardware, des NI-CAN Hardware and Software Manuals unter
USB-847x.

3. Fahren Sie mit dem Abschnitt Priifen der Installation fort.

Priifen der Installation

1. Schalten Sie IThren Computer ein und starten Sie Windows.

Moglicherweise wird zunichst das Dialogfeld “Neue Hardware gefun-
den” angezeigt. Wenn das Dialogfeld nicht automatisch ausgeblendet
wird, wéhlen Sie die Standardoption Automatische Installation der

Software (Empfohlen) und lassen Sie das Betriebssystem die Treiber-
dateien installieren.

2. Starten Sie den Measurement & Automation Explorer (MAX) und
aktualisieren Sie die Ansicht, indem Sie <F5> driicken oder
Ansicht»Aktualisieren aus dem Menii auswihlen. IThre CAN- und
LIN-Geriite sollten jetzt unter Gerite und Schnittstellen angezeigt
werden. Um alle gefundenen CAN- und LIN-Gerite zu testen, wéhlen
Sie Werkzeuge»NI-CAN»Alle lokalen Karten testen.

3. Fahren Sie mit dem Abschnitt Anschliefsen der Kabel fort.

AnschlieBen der Kabel

SchlieBen Sie nach dem Einbauen der Gerite die Kabel an. Die Verkabe-
lung von CAN- und LIN-Geriten ist in Kapitel 4, Connectors and Cables,
des NI-CAN Hardware and Software Manuals beschrieben.
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Deinstallieren der NI-CAN-Software

Gehen Sie zur Deinstallation von NI-CAN unter Windows 2000/XP wie
folgt vor:

1.  Wihlen Sie Start»Systemsteuerung»Software.

2. Wihlen Sie National-Instruments-Software. Klicken Sie auf die
Schaltfliche Andern.

3. Waihlen Sie aus der Liste NI-CAN und klicken Sie auf Entfernen.

Zur Deinstallation von NI-CAN unter Windows Vista gehen Sie wie folgt
VOr:

1.  Waibhlen Sie Start»Systemsteuerung»Programme»Programme und
Funktionen.

2. Wihlen Sie National-Instruments-Software. Klicken Sie auf die
Schaltfliche Deinstallieren.

3. Wihlen Sie NI-CAN aus der Liste und klicken Sie auf Entfernen.

Bei der Deinstallation werden alle Ordner, Hilfsprogramme, Geritetreiber,
DLLs und Registry-Eintrige von NI-CAN entfernt. Bei der Deinstallation
werden jedoch nur Elemente entfernt, die zuvor installiert wurden.

Wenn Sie eine Datei einem der vom Installationsprogramm erzeugten
Ordner hinzufiigt haben, kann dieser Ordner nicht geloscht werden, da er
nach der Deinstallation nicht leer ist. Loschen Sie dann alle verbleibenden
Elemente manuell.

Starten Sie IThren Computer nach dem Ende der Deinstallation neu.

Weitere Dokumentation

Alle weiteren Informationen finden Sie im NI-CAN Hardware and
Software Manual, das sich als PDF-Datei auf der CD NI-CAN-Software
fiir Windows befindet. Darin ist auch ein Abschnitt mit der Uberschrift
Troubleshooting and Common Questions enthalten, wo Sie weitere Infor-
mationen zur Installation und Konfiguration Ihrer NI-CAN-Software und
-Hardware erhalten. Die Datei heilt NI-CAN Hardware and Software
Manual . pdf und wird im Ordner NI-CAN\Documentation auf der Fest-
platte installiert.
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