Class #4: Experiment
Circuit Simulation with LTspice IV
Purpose: The objectives of this experiment are to gain some experience with the tools we use (i.e. the electronic test
and measuring equipment and the analysis software) and to gain some fundamental understanding of voltage dividers.
Background: Before doing this experiment, students should be able to
 Determine the values of series and parallel combinations of resistors
 Identify the audible frequency spectrum in humans
 Identify the value of standard, low wattage resistors from the color and pattern of their stripes
 Download and install software on a Windows machine
Learning Outcomes: Students will be able to
 Simulate a simple resistive voltage divider and demonstrate conditions under which measurement devices (e.g.
DMM or oscilloscope) significantly affect the operation of the circuit. Then, use the changes in voltages caused
by the measurement devices to determine the resistance of the measurement device.
 Be able to set up the numerical analysis of simple resistive circuits driven by constant and periodic voltage
sources.
 Simulate and display the voltages in a simple resistive circuit driven by a sinusoidal voltage source.
 Fully annotate voltage plots obtained from simulated experiments, including such signal characteristics as
frequency (both types), period, amplitude, average or DC offset, etc. and identify where on a standard circuit
diagram the voltages are found.
 Articulate a series of questions posed about simple circuits and answer the questions using fully annotated data
obtained both from physical and simulated experiments.
 Develop the circuit model of a physical battery using an ideal voltage source and an ideal resistor.
 Calculate the power delivered by a battery and dissipated in a resistor.
Equipment Required
 None

Pre-Lab
Required Reading: Before beginning the lab, at least one team member must read over and be generally acquainted
with this document and the other required reading materials listed on the course website.
Hand-Drawn Circuit Diagrams: Before beginning the lab, hand-drawn circuit diagrams must be prepared for all
circuits either to be analyzed using SPICE or physically built and characterized using your Analog Discovery board.
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Part A – Sine Waves and Hearing
In this exercise, a function generator will be used to produce electrical signals with various shapes, including sine
waves. Our objective is to learn about the basic properties of sine waves and related signals by seeing them, hearing
them and analyzing them with the oscilloscope and audio output capabilities of the Analog Discovery. You will need
a set of ear buds or something similar to hear the audio. We will also demonstrate some interesting facts about human
hearing and speech.
Background
Equipment: What formerly would require the use of an entire workbench of equipment can now be accomplished
using the Analog Discovery (see Figure A-1 below) and a laptop computer. This board, coupled with the Digilent
Waveforms software, can produce the same functionality as each of the following pieces of equipment (and more): a
two channel oscilloscope (scope), a digital voltmeter (DVM), two DC power supplies and a two channel function
generator. The digital voltmeter (DVM) has 2 channels (Here we use the Scope Channel 1+ (Orange) and Scope
Channel 2+ (Blue)). (In Wavesforms 2015, use Logger) The scope is a measuring device that lets you view a plot of
a voltage signal vs time. The DC power supplies generate constant DC voltage signals (like a battery). The function
generator creates a voltage signal that varies with time. The PC is an integral part of the equipment setup. You use it
to simulate many of the circuits you will build (using a SPICE program), as well as to operate Analog Discovery.

The function generator can be programmed to generate waves with specified amplitude and frequency. Ear buds and
speakers convert an electrical signal to sound that we then can hear. The oscilloscope analyzes an electrical signal
and displays a picture of the signal. The combination of the oscilloscope and audio output allows us to see with our
eyes what we are hearing with our ears. The two function generators are labeled as Waveform Generator W1 (Yellow)
and Waveform Generator W2 (Yellow/White). We will start with only one of the function generators in this
experiment (Waveform Generator W1). See Figure A-1.
The sine wave equation: All of us should have studied the sine and cosine trigonometric functions in math and physics
classes. A sine wave is described by an equation of the form v (t) = A sin (2ft) = A sin (t), where the variable t
represents time. We use the term "wave'" because the shape is similar to a water wave that you might see on an ocean
or a lake. As shown in Figure A-2, a sine wave is characterized by two parameters, called amplitude (A) and frequency
(f). The amplitude A determines the maximum value that the sine wave achieves along the vertical axis. The sine
wave takes on values between +A and -A at various times.
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Figure A-1 Analog Discovery & Pin-Out Diagram
The frequency f of the sine wave can be understood as follows. Notice that the sine wave reaches its peak value of
+A at regular intervals. The time between adjacent peaks is called the period of the sine wave. The period is denoted
by the letter T and it is measured in units of seconds (sec). The frequency is defined as the number of times per second
that the sine wave achieves the peak value of +A. Since adjacent peaks are separated by T sec, the wave achieves 1/T
peaks per second. Hence the frequency f is equal to 1/T, and the units of frequency are sec -1. Another name for the
unit sec-1 is Hertz, or Hz for short. It is usual to denote the product 2f as , where  is called the angular frequency
in electronics. (In physics, this is the rate of change of the angle in a rotating system, called angular velocity.) Note
that one of the most common mistakes made in this class is confusing f and .

2A

Figure A-2. Sine wave with amplitude A, frequency f, and period T.

Figure A-3

Adding a DC offset: If we add a DC offset voltage to the sine wave signal, as shown in Figure A-3, it moves the wave
such that it is centered around VDC, the DC offset. The equation becomes v (t) = A sin(2ft)+VDC. In electronics, the
AC and DC parts of a signal can be treated as two mutually exclusive entities.
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Scalar measurement of sine waves: Measurement devices do not usually give us the voltage amplitude A directly.
Rather they determine VP-P (the peak-to-peak voltage) or VRMS (the RMS voltage). The peak-to-peak amplitude is the
difference between the largest positive value of the sine wave and the largest negative value of the sine wave, so it
should be nearly equal to A - (-A) = 2A. The RMS value is determined by taking the square root of the average of the
square of the voltage. Since the voltages here are sinusoids VRMS  V 2  V 1.414 . Note that in electronics the
RMS voltage depends only on the time-varying amplitude and not on any offset.
Impedance and resistance: You should be familiar with the term resistance. It is a measure of the degree to which a
resistor resists the flow of electrons. Circuits that have a combination of components (some of which are not resistors)
also affect the flow of electrons. However, the behavior of these circuits is more complicated because it varies with
the frequency of the signal. We call this complicated response “impedance.” Both resistance and impedance are
measured in Ohms () and the terms are often used interchangeably.
Human hearing: We are exposed to a wide variety of sounds every day. We hear a sound after our brain processes
the sensations recorded by our ears. Two attributes that are commonly used to characterize sounds are loudness
(amplitude) and pitch (frequency). Loudness, of course, refers to how loud or intense we perceive the sound to be.
Pitch refers to whether we perceive the sound to be high or low. For example, the sound of an ambulance siren has a
higher pitch than the sound of a fog horn. Keep in mind that your ear is a biological system. It is designed to hear
certain pitches better than others even though, technically, they have the same loudness.
Experiment
A.1) Setting up a Sine Wave on the Function Generator
For the first experiment, we need to set up a sinusoidal voltage. Set up Analog Discovery to generate a signal from
function generator 1 (W1, GND) and measure it with scope channel 1 (1+, 1-). This can either be done by connecting
the wires directly (Orange to Yellow and Orange/White to Black) or using a protoboard. Both options are shown in
Figure A-4. Note that the connection pins that come with Analog Discovery can be broken apart, but it is helpful
often to have some remain in pairs or other combinations.

Figure A-4
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After correctly installing the Digilent Waveforms software and connecting the Analog Discovery, open the software
and select the WaveGen (for the function generator) and the Scope (for the oscilloscope) from the Digilent Waveforms
window. You should see the window similar to that shown in Figure A-5 (with ‘Basic’ selected) for the function
generator and the window shown in Figure A-6 for the scope. The values for various parameters shown in both
windows will likely be different. We will set those up next.
Function Generator:
 First we will set the frequency. The frequency of the function generator is adjusted as follows:
 Make sure that you choose the channel or channels you are using in the “Channels” menu. The default choice
when Waveforms starts is usually Channel 1 (AWG1). If this is the case, you do not need to use the Channels
drop down menu. We only need one Function Generator in this experiment. Note that we will use Function
Generator and Arbitrary Waveform Generator (AWG) pretty much interchangeably. This system can produce
any time-varying signal, so it is an AWG, but we mostly use it to produce sine, triangular and square waves
like a function generator.
 Make sure that the “Frequency” box is checked and AWG configuration mode is “Basic”. Select the
“Frequency” box or drag the “frequency bar” for Ch.1. Set it to display 1kHz.
 Amplitude: Make sure the Amplitude is checked. Set the voltage amplitude to 200mV.
 Your WaveGen window should look like Figure A-5. Make sure
is showing.

Figure A-5
Scope:
 First we set up the vertical and horizontal scales for the display. On scope channel C1, select the Volts/div to
100mV, the offset to 0 V. Uncheck C2, since we will not be using channel 2. The Time/div should be set at
200µs/div. The voltage and time scale settings are found on the right hand side of the scope window.
 To make a measurement, connect the source (W1) to scope input (1+) and scope input (1-) to ground. Make sure
the connections you made above are good.
 When you are ready, press the “Run AWG1” button on the WaveGen and the “Run” button on the Scope. These
are the ‘On’ buttons for the function generator and scope, respectively. If you cannot see a signal on the scope,
double-check to make sure all of the settings are correct.
 It is useful to know how to copy plots and paste them into word. In the upper left hand corner, under the Files
menu, select Export. Select the Images tab and you can save the Oscilloscope screen to a file or use the Copy to
Clipboard option to put the image directly into your laboratory report. Save a copy of the Oscilloscope plot for
your report.
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Change the frequency up or down as desired. How does this change the signal on the scope? The purpose of this
step is to see what kind of signals this setup can produce. You should play around a little with different
frequencies, voltage amplitudes, signal shapes, etc.
Set WaveGen again so the display reads 1kHz and the amplitude is 200mV with no offset. Use the ‘Copy Window
as Image’ option in the Edit drop down menu on the Scope and paste the image in your report document. Clearly
label both the amplitude and period of the signal you have measured.

Run Button

Time and voltage scales

Figure A-6

A.2) Using the Audio Output from Analog Discovery
We now wish to connect the function generator, the scope and earphones to perform some simple experiments.




Start by measuring the resistance of each channel for your ear buds or earphones (from left or right to ground or
common) using a desktop or handheld DMM. We only need an approximate value for the resistance, so any
device can be used for this purpose. There are typically two types of connectors used for earbuds, depending on
whether or not a microphone is included. Both are shown below.
 Plug your ear buds into the audio output on the
Analog Discovery. Do not do this with the ear buds in
your ears. The volume may be too high. It is prudent to
turn on the volume with the ear buds away from your ears
and bring them closer until you are sure the volume level
is comfortable. You should hear only one channel. If you
use both AWG sources you will hear both channels.
 Adjust the volume of the signal to a comfortable level
by changing the amplitude of the signal. By comfortable level, we mean the lowest amplitude that allows you to
hear a distinct sound. What is the value of the voltage amplitude that you have selected?
Let us investigate how our perception of loudness changes as the frequency of the sine wave is varied. With the
sine wave amplitude fixed at your comfortable level, vary the frequency over the range from 100Hz to 10,000Hz.
Try cycling through the following frequencies, without changing the signal amplitude: 100, 200, 300, 400, 500,
600, 700, 800, 900, 1000, 2000, 3000, 4000, 5000, 6000, 7000, 8000, 9000, and 10,000Hz. Which frequency do
you hear the loudest? Is there any variation among the members of your team? If you have problems discerning
significant differences in loudness, try a different set of ear buds.

Experiment with the Equipment
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At this point, you will have put the function generator and scope through some basic tasks. Experiment with the other
features of the function generator and see what happens. Some very interesting and annoying waves can be produced.
Play around a little and then find a particular set of operating conditions that you find the most interesting. Under
what circumstances might you experience the sounds you have produced or generally when might you encounter a
waveform like the one you have displayed on your scope?
Summary
You should now know how to set up voltage signals with the function generator feature, connect the function generator
output to the scope input and display them using the oscilloscope feature. You should understand the pitch/frequency
and amplitude/volume relationships, and know how these relate to human hearing.
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Part B – Introduction to LTspice IV
In this section we will learn about the circuit analysis software we will use as our primary simulation tool. You should
download and install this software on your laptop. It is recommended that you install the latest version.
Background
The software we will be using to simulate the operation of circuits in this course is called LTspice IV which takes
information on a circuit and analyzes how it will behave. When placing parts in the circuit, resistors, capacitors,
inductors, diodes and wires all have their own symbols in the menu. All other parts are accessed through the “Place
Parts” button. Once the parts are places, their values must be specified. This is usually done by right clicking your
mouse on the circuit element or one of its parameters. Once the circuit is complete, the simulation must be setup. This
is done through the ‘Simulate’ drop down menu. The example below shows a transient simulation that runs from 0 to
5ms with a maximum step size of 1µs. Once the simulation is run, it displays an output similar to what you would see
if you hooked the circuit to an oscilloscope. Figure B-2 contains a sample diagram.

Ground

Create Edit Run
SIMULATION

Place Wires

Place Parts

Resistor Value
Voltage Supply Specification

Figure A-1.

Figure B-2.
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Experiment (Simulation)
Opening a New Simulation
In this part of the experiment, we will draw the simple circuit we have been studying, a combination of resistors and
a sinusoidal voltage source representing a resistive divider with voltages measured by Analog Discovery.


Run the “LTspice IV” program



It will open with no existing simulation. Click on the File pull-down menu and select New Schematic. You will
name your project when you save it. You should also decide where you want to save schematics. You will have
to choose a directory when you save your work.

Drawing a Circuit
Figure A-3 is a picture of the LTspice IV main screen with the circuit we will be drawing. Note that this is the
circuit used in Figure B-7 from the previous experiment including the input resistance of one channel of the Analog
Discovery as R3.

Figure B-3.
In the circuit shown in Figure B-3, we have some resistors, a sinusoidal voltage source, a ground and some wires. To
create this diagram, we will use the command buttons. For the resistors we will click on the button that looks like a
resistor. You can also do this by using the Edit menu or by hitting the R key. You should see a resistor symbol that
you are free to place anywhere in the schematic. The Edit menu also shows you what name goes with every symbol.
For the ground, select the ground button, use the Edit menu or hit the G key. For the voltage source and most other
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components, you have to use the component button
pick Voltage from the many options offered.

(which can also be identified from the Edit menu) and then

Figure B-4.





When you have finished placing resistors or doing just about anything else, hit the Esc key to get back to the basic
diagram.
When you have placed all resistors, the voltage source and the ground, connect everything with wires. Access
wires by clicking on the symbol that looks like a pencil, next to the ground button.

Figure B-5.
To complete the schematic, we have to change the component values. Each resistor was given a name in the
order it was placed on the diagram. Thus, your resistors may not have the same names as shown above. However,
for simplicity, they will be referred to by the name shown here and you can change the names if you wish the
same way their parameter values are changed. To change R3 to 1Meg Ohm, right click on the bottom R and you
should get the window shown in Figure B-5. Change the R to 1MEG. If you find that the number or anything
else is in a hard to read position on the circuit diagram, move it with the mouse by first clicking on the Move
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button that looks like a hand
. When you type the value of the resistance, you must type 1MEG with no
spaces. Note that you have to type MEG since SPICE uses M to mean 10-3 and MEG for 106. It is not case
sensitive. Note that in the schematic pictured, R1 and R2 are the resistors in your voltage divider and R3
represents the impedance of the scope. Since the scope impedance is 1M, R3 should be 1MEG. R1 and R2 should
be 1k Ohms. .
After you have changed all the resistor values and moved them to readable positions, you must set up the voltage
source. In LTspice IV, voltage sources are DC by default. To specify the source as sinusoidal, right click on the
voltage source symbol and select the Advanced button. The window in Figure B-6 will appear. Select SINE and
then set the values shown for offset, amplitude and frequency. Once the symbol is labeled as SINE, these
parameters can be changed by right clicking on the symbol. The values are used to label the voltage source as
shown in Figure B-3.

Figure B-6.
Setting Up the Analysis
After we have defined all the components, wired them up and changed their values appropriately, we are ready to do
some analysis.
 Find the Simulation drop-down menu and click and select Edit Simulation Cmd. You will get the window shown
in Figure B-7. Select the tab for the type of analysis you wish to perform. In this case it is Transient since we are
interested in output that is time-dependent like a scope. The simulation will begin at time t = 0, but we can choose
to start saving data after that. Thus, we specify the Stop Time (the end time of the simulation), the Time to Start
Saving Data, and the Maximum Timestep (the resolution of our simulation). Here we choose, 5ms, 0 and 1µs,
respectively. Note that there is no µ so we have to use the letter u.
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Figure A-7.



The final time (Stop Time:) has been set at 5ms because the period of a 1kHz sine wave is 1msec. This allows us
to see five periods. The Maximum Timestep needs to be set so that you get a reasonable representation of the
output. A step size that is too small will take a long time to run, a step size that is too big will give you an undersampled representation of the output. A step size between 1/100 to 1/1000 of the run time is reasonable. The
analysis will begin saving data at 0 seconds. Note again that there should never be any spaces between the number
and its units. Click on the OK button when you are finished putting in the numbers. You will be able to place
the information on the simulation anywhere on your circuit. Choose a space where it is easy to read and does not
block anything else.
When you have finished, you can run the simulation either by pushing the button that looks like a stick person
running or select Run from the Simulation drop-down menu.

Transient Analysis
You are now ready to do the simulation.


Click on the Run button. A set of axes with no signals shown will appear. You can now add voltages where ever
you wish by left-clicking with your mouse. You will see that whenever you hover over a wire with your mouse,
a symbol like a voltage probe will appear. Click where you want to know the voltage. If you want to plot current,
hover over a device symbol and your mouse symbol will change to a current probe. If you click on a device, the
current through it will appear on the plot. In the plot shown in Figure B-8, the input and output voltages for the
voltage divider are displayed. Note that the ratio between the two is what you should expect for this simple circuit.
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Figure A-8.




You should get something like (but maybe not identical to) the window shown above. The voltage divider
expression we used in the previous lab can be applied to sinusoidal signals as well. For sinusoidal signals, the
amplitude of the sine wave changes based on the voltage divider ratio. We can then perform the same comparison
between source voltage amplitude and resistor voltage amplitude as we did in Laboratory 3 where we compared
the source DC voltage and the resistor DC voltage. For the 1kΩ voltage divider circuit, do we see the same ratio
of voltage amplitudes as seen for DC voltages in Laboratory 3?
It is also useful to know how to copy plots and paste them into word. Under the Tools menu, click on “copy to
clipboard”. Now there is a bitmap in the clipboard that you can paste into any application. Open word and paste
the bitmap in. Save this file or print the output plot for the 1k voltage divider directly. You should see a plot like
the one shown below. If you get the circuit diagram instead, click your mouse on the voltage plot and try again.

Note that the sine wave lines on the plot can be a bit thin and hard to read. You can change the data display on
the plots generated by selecting Control Panel from the Tools menu and then selecting Waveforms. Select Plot
data with thick lines. They will be much easier to see.



Change the values of the resistors in the voltage divider to 1MEG and rerun the simulation. Save or print this
plot as well. Both plots should have two traces: the source voltage, and the voltage across the resistor closest to
ground. For the 1MegΩ voltage divider circuit with the 1MegΩ probe resistor, do we see the same ratio of voltage
amplitudes as seen for DC voltages in Laboratory 3? Try varying the frequency, amplitude and offset of the VSIN
source one at a time and rerun the analysis. What happens to your signal? Is the amplitude ratio still the same?
Does it make sense based on your knowledge of sine waves and voltage dividers?
Show your results for the 1MEG simulation to a TA or instructor and have them sign your hand-drawn circuit
diagram for this simulation.
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For this and other signatures you obtain in this course, you must explain:
 the purpose of the data (using your hand-drawn circuit diagram),
 what information is contained in the plot and
 why you believe that the plot is correct.
Any member of your group can be asked for the explanation so present your information
together..
Summary
LTspice is a very powerful simulation tool meant to address the circuit simulation needs of all engineers who must do
circuit design and analysis. Thus, there are many, many opportunities to make what seem like silly mistakes that
prevent the analysis from working properly. In your first attempt at using these tools, it is likely that you have already
made some of these mistakes. You should also have heard about some of them in class. What mistakes did you make?
Report
For your report, follow the template proved on the course website. Be sure to include your hand-drawn circuit diagrams
and fully annotate all plots so that the questions you are addressing can be easily answered using the plot alone rather
than reading the accompanying text.
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